RFI from LED Lights

Ventucky Red

Pattern Altitude
Joined
Jan 9, 2013
Messages
1,967
Display Name

Display name:
Jon
Has anyone here had any issues with putting in LED light in your plane? Seem the few folks I talked to noted no issues, but this is a small sample...
 
My panel lights pulse with the strobe lights. My next troubleshooting exercise is to find the best quality panel bulbs available, whatever that is.
 
We had a white tail LED that would switch from steady to strobe with a toggle of the nav light switch. That thing created enough RF noise to throw off the GMU11 signal to the G5.

Replaced it with a Whelan and problem solved.
 
Tangent - My external garage door key pad stopped working. Would open the door and then not work, or would close the door after a while but would stop again. Did a lot of trouble shooting for a couple of days, and the culprit? The LED lightbulbs in the opener were old and caused enough RF interference it prevented the outside key pad signal from working. New LED bulbs and problem solved.
 
Last edited:
LED's cleaned up a magnetometer issue I had with conventional strobes. I'd get a heading error due to interference. Whelen LED strobes and nav lights and no more issues. No RFI issues with radios either.
 
I had significant RFI from just about any LED landing light(s) I installed.

I ended up putting this on the circuit and it fixed any RFI issues:
 
I have a led bulb in my overhead cabin light that causes lots of noise/static in my radios. Makes them un usable. Luckily I only use it while on the ground at night sitting on the ramp. So I kept it since the light is better than the original bulb.
The Wat led nav lights don't cause any problems. Wat led landing lights don't cause any problems.
The led lights in my hangar causes noise on the hangar radio.
 
Huge noise with my non-Av* landing lights.
Have to turn them off to clearly hear taxi instructions.
It’s common.
* I’m exp.
 
Tangent - My external garage door key pad stopped working. Would open the door and then not work, or would close the door after a while but would stop again. Did a lot of trouble shooting for a couple of days, and the culprit? The LED lightbulbs in the opener were old and caused enough RF interference it prevented the outside key pad signal from working. New LED bulbs and problem solved.
When I put in my new Genie garage door opener the instructions specifically stated to NOT use LED bulbs do to interference. A few years later, they came out with LED bulbs that would work.
 
  • Like
Reactions: WDD
Back
Top